Our full technical support staff does not monitor this forum. If you need assistance from a member of our staff, please submit your question from the Ask a Question page.


Log in or register to post/reply in the forum.

Loggernet upgrade from 4.3 to 4.5 broke tasks


Kevin May 2, 2018 12:00 AM

Hi. I upgraded loggernet today from v4.3 to 4.4, then 4.4 to 4.5

The upgrade worked but the tasks that run after a scheduled  interrogation broke... their was no tasks left configured after the upgrade.

Are you aware of this happening? 


ChipsNSalsa May 2, 2018 10:19 AM

I don't recall any reports of such an issue when upgrading.

When upgrades/patches are performed, our installs are designed to backup the existing network and configuration files to C:\Campbellsci\LoggerNet\NetworkMapBackup\version_folder. You could try closing LoggerNet 4.5 and then copying the tasks.xml file from C:\Campbellsci\LoggerNet\NetworkMapBackup\4.3\sys\bin to C:\Campbellsci\LoggerNet\SYS\bin and then starting LoggerNet 4.5 back up again. The tasks may show up again. Other than that, your other option is to zip up the contents of C:\Campbellsci\LoggerNet\NetworkMapBackup\4.3\sys\bin and send it to our support team to examine.


Kevin May 2, 2018 04:57 PM

Hi.  Thanks for the feedback...

I checked the tasks.xml file from both C:\Campbellsci\LoggerNet\NetworkMapBackup\4.1\sys\bin & C:\Campbellsci\LoggerNet\NetworkMapBackup\4.4\sys\bin and the xml was only 1kb - didnt contain my 50+ tasks.

Thankfully the file C:\Campbellsci\LoggerNet\NetworkMapBackup\4.4\sys\inifiles\Taskmaster.ini gave me enough information on what tasks I had setup and the batchfiles that were called.  I had to manually recreate all the tasks.

I will take a copy of tasks.xml just incase I have issues again in the future.


Steve Mar 6, 2019 10:17 AM

I've had this happen more than once (it is not uncommon) and am currently dealing with a complete loss of tasks in the scheduler that were there a week ago.  Can anyone tell me where they are saved? C:\campbellsci or in the program files or somewhere else?


ChipsNSalsa Mar 6, 2019 11:00 AM

It doesn't sound like quite the same scenario Steve. It doesn't sound like you were upgrading LoggerNet. What version of LoggerNet are you running and can you provide any more details leading up to the loss of tasks?


Steve Mar 6, 2019 11:31 AM

Hi,

I've had it happen in the past when transistioning to new computers, i.e. copying files and the tasks go missing.

Current problem is a mystery. I just logged in remotely to a polling computer to find none of the tasks there.  LoggerNet 4.5 build 4.5.0.1

I haven't checked the anti virus logs yet for what has been deleted which might be the issue.

Thanks.


Steve Mar 6, 2019 12:37 PM

No clues in the antivirus quarentine.

Log in or register to post/reply in the forum.