Our full technical support staff does not monitor this forum. If you need assistance from a member of our staff, please submit your question from the Ask a Question page.


Log in or register to post/reply in the forum.

GPS Signal from MetSENS Compact Sensors


ronlootensVU Apr 29, 2019 03:55 AM

Dear Metsens users,

Is it possible to use the GPS information from this sensor to keep the time in the dataloggers (CR300, CR1000 series) accurate within 100mS or do I need a separate Garmin sensor? (I do not nieed the 10 uSec. from the PPS output.)

Any information/suggestion is welcome

Ron


Nicolas Jun 8, 2021 03:55 AM

Hello, have you found a solution?
Thank you


pokeeffe Jun 8, 2021 06:02 PM

Yes it's possible to use the `GPS()` instruction with GPS data from a MetSENS (or any other NMEA 0183) sensor but without a PPS signal the accuracy will be much less (e.g. ~1sec not 100ms). 

It also means any non-GPS data will have to be manually extracted from the relevant sentences. Check out the `GPSArray` and `NMEASentences` parameters in the CRBasic `GPS()` help article.


Nicolas Jun 9, 2021 04:32 AM

Thank you


JDavis Jun 9, 2021 04:03 PM

The MetSENS shipped from Campbell Scientific do not have the optional GPS unit installed, and are not configured to output NMEA 0183 format.


Nicolas Jun 12, 2021 09:46 AM

Thank you,

I'm trying to establish communication between a CR300 (new and last OS update) and a GPS (NMEA 0183 V3.01: GGA, GSA, GSV, RMC, VTG - 9600 bps) with this simple code.:

   SetSetting("Baudrate(COM1)",9600)   

   Scan (1,Sec,0,0)     

   GPS (latitude_a,COMC1_RX,C2,LOCAL_TIME_OFFSET*3600,100,nmea_sentence(1),9600)    

As you can imagine, it doesn't work (tested with or without a PPS signal), I get NAN for all the frames coming from the GPS.

On the oscilloscope, I have a PPS signal of 3.3 V at 1 Hz as well as the data frame from the GPS (@ 5V). The data frame is approximately 910ms (always less than 1000ms).

The PPS parameter always return approx. 550 ms (that it is transmitted on C2, SE1, ...)), i don't understand.

On the terminal (7: COM RX), I have no data

I don't know what to test anymore. Please, do you have an idea ?

Thank you,

Nicolas

Log in or register to post/reply in the forum.