Our full technical support staff does not monitor this forum. If you need assistance from a member of our staff, please submit your question from the Ask a Question page.

Log in or register to post/reply in the forum.

Connection stability CR1000 COM110 GPRS

FRphil Feb 11, 2013 09:29 AM

Hello all,
I use a CR1000 and a COM110 modem with a dynamic address. The station communicates via GPRS. When I send a call back from the station to the Loggernet server (fixed public IP) The Server catch the IP address of the station, the link tries to establish and after a few seconds (online appears in front of the CR1000 in the status monitor), the link is lost and it retries.
Why does my system can't keep the link ?

Here is an extract from the communication log :

"2013-02-11 4:23:40 PM","IPPort_2","S","Starting wait for callback"

"2013-02-11 4:23:41 PM","IPPort_2","S","Waiting for connection on port 6785"

"2013-02-11 4:23:41 PM","IPPort_2","S","Socket Connected","","1276"

"2013-02-11 4:23:42 PM","PakBusPort_2","S","Connected via callback"

"2013-02-11 4:23:42 PM","PakBusPort_2","S","received message","src: 3","dest: 4095","proto: PakCtrl","type: 0x0e","tran: 0"

"2013-02-11 4:23:42 PM","CR1000_2","S","PakCtrl message received","0e"

"2013-02-11 4:23:42 PM","PakBusPort_2","S","sending beacon","src: 4094","dest: 4095","proto: PakCtrl","empty"

"2013-02-11 4:23:43 PM","PakBusPort_2","S","received message","src: 3","dest: 4094","proto: PakCtrl","type: 0x09","tran: 5"

"2013-02-11 4:23:43 PM","CR1000_2","S","PakCtrl message received","09"

"2013-02-11 4:23:43 PM","PakBusPort_2","S","link added","4094","3"

"2013-02-11 4:23:43 PM","PakBusPort_2","S","sending message","src: 4094","dest: 3","proto: PakCtrl","type: 0x89","tran: 5"

"2013-02-11 4:24:16 PM","PakBusPort_2","S","sending message","src: 4094","dest: 3","proto: BMP5","type: 0x18","tran: 215"

"2013-02-11 4:24:36 PM","PakBusPort_2","S","sending message","src: 4094","dest: 3","proto: BMP5","type: 0x17","tran: 216"

"2013-02-11 4:24:38 PM","PakBusPort_2","S","link lost","4094","3"

"2013-02-11 4:24:38 PM","CR1000_2","F","transaction failure","unreachable destination","Get Logger Program Status"

"2013-02-11 4:24:38 PM","CR1000_2","F","transaction failure","unreachable destination","check/set clock"

"2013-02-11 4:24:38 PM","IPPort_2","F","unexpected socket error","10053","software caused connection abort"

"2013-02-11 4:24:39 PM","IPPort_2","S","Starting wait for callback"

aps Feb 11, 2013 10:11 AM

That shows you the communication exchange started OK, but then the CR1000 stopped responding to requests for data. Finally Loggernet gave up, hence the link lost message.

It can then not make further exchanges out to the logger because because the original socket connection is genuinly broken and a new outgoing connection cannot be made because incoming IP address Loggernet detected is not that of the modem but of a router, which is between the modem and the public internet.

As a first step I would check the signal strength at the modem and the battery voltage on the system. Also check you have not set too long an "extra response time" - a value of 2-3 seconds is the maximum normally required.

FRphil Feb 13, 2013 03:46 AM

Thank you for answering so quickly.
Battery voltage : I use an AC/DC converter (15V), in the station status it seems to be good.
I've tried with an extra response time of 1 and 2 seconds
How to check the signal strength at the modem ?

The weird thing is :
In the command prompt of my computer (the one with Loggernet) The link between the CR1000 and the computer is "established" BUT I can't ping the CR1000.

Does the communications process works with NAT ? Because my computer (with LN) is on a network based on a Network Address Translation (NAT) system.

Thank you in advance

aps Feb 13, 2013 04:26 AM

You can check the signal strength of the modem, by either connecting it to a PC and using the AT+CSQ command (details in the CS-GSM manual) or using the talk-through option you can send the same command via the logger, once you have stopped the PPP connection.

It is also worth checking the LED status on the modem. Check the LED is flashing on and off every couple of seconds and not staying on for long periods (which would indicate you are dropping off the network).

In respect of Ping and NAT, on most European networks, devices with standard dynamic IP SIMS are on private networks behind a router doing NAT. Because of this you cannot instigate connections to the device (logger) from the public internet, and that includes pinging it.

If your loggernet server is also behind a NAT router, then I presume you have setup port forwarding to the server (it would seem so as you have got incoming connections). This would not stop you pinging an external device, if reachable (which for the reasons above is unlikely), unless you had locked down the firewall in the router very tightly.

FRphil Feb 13, 2013 08:56 AM

I've tried the AT+CSQ instruction, it answer me " +CSQ : 28,0"
28 means between -109 and -53 dBm.
It seems to be strong enough. The problem could be in the firewall ? because it's already open for the ports that I use.
Something else:
I have the CR1000+SC105+COM110 on my desk, it's linked to a computer with loggernet in direct (RS232/USB cable). By using the "connect screen" and the num display function, I visualize the values of the variables in the CR1000.
When he communication sets up, the "ppp_state" value indicates [i]dialing->dialing[i/] and [i]dial failed[i/] a few times before resolving the IP address. Why does it takes a long time to resolve the IP adress? Is it linked with the main problem ?

Thanks in advance

aps Feb 13, 2013 09:09 AM

The signal strength is fine.

During the PPP connection you would not normally see a dialling failed message unless the modem is not on the network or is getting the connections rejected by the network. Sometimes this can happen on some networks if you disconnect abruptly (power loss) or even disconnect and reconnect quickly as the backend servers can take a while to realise you have gone and are trying to log back on, on some networks.

Ignoring that for the time being, you may be causing some of the connection issues by having the dual connection to the logger via Loggernet. This is an acceptable thing to do but you must make sure the two Pakbus Ports for the two different connection methods are different otherwise the logger gets confused as to which logger it is talking. By default the PB address is 4094 for any new port. You need to change one of the ones you are using in the Loggernet Pakbus settings screen which can be found under the Setup, Options menu. Change one to something else in the 4000 range.

FRphil Feb 13, 2013 10:37 AM

Great! Now it works sometimes (once for 5 tries). The other 4 times, ppp_state stays stocked in a "dialing and dial failed cycle". What could be the source of such a problem.

aps Feb 14, 2013 02:53 AM

Not sure, can you tell me what dial string you are using and the network.

FRphil Feb 14, 2013 05:54 AM

The dialstring used is : AT+CGDCONT=1,"IP","internet-entreprise";ATD*99***1#

aps Feb 14, 2013 06:07 AM

Please try using just the basic dial string *99***1#, the logger will add the ATD.

It is not necessary to keep entering the APN each time as it can slow down the connection. (This can be SIM dependent)

Also make sure you have the latest operating system in the logger as the timeout on the connection process has been extended over the years.

FRphil Feb 15, 2013 01:41 AM

It seems a little bit faster. But the "dial failed" happens quite often. I think that my major problem is in my program. Do you have an example of a program using CallBack every x minutes ?

aps Feb 15, 2013 07:30 AM

Can you tell me if you are attempting to turn the modem on/off between calls?

FRphil Feb 18, 2013 01:26 AM

Yes, if possible.

aps Feb 18, 2013 08:24 AM

Can you please drop me an email and I will send a copy of a rather comprehensive example written by a colleague. It is too long to post here.

Email me at: andrew dot sandford at campbellsci dot co dot uk

resistivity Apr 27, 2013 04:50 PM

Hello Everybody,

We are having a lot of the same error issues when we try to connect remotely to our CR1000. The only difference is that we're connecting over a Sierra Wireless - Raven xt with a fixed IP address. Most of our errors are "unexpected socket error" and "check/set clock".

Do you have any suggestions for what we might try?
we have our Pakbus set to 1.

Thank you for all your help,

kiko Nov 20, 2015 07:34 AM


was this problem solved, having the same problem here, allready tried the things in post, no result


Log in or register to post/reply in the forum.